n-Track Bug Tracking - Show Open Bugs - Show All Bugs - Forum

Bug 10 - Error Initializing ASIO driver (.. and Customize Skin Lock up)
: Error Initializing ASIO driver (.. and Customize Skin Lock up)
Status: RESOLVED FIXED
: n-Track
Main program
: 6.x
: PC Windows
: P5 critical
Assigned To:
:
:
:
  Show dependency treegraph
 
Reported: 2008-11-22 21:37 by
Modified: 2008-11-25 03:20 (History)
32 or 64 bit version:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-11-22 21:37:17
On start up I get 4 small dialog boxes saying "Error Initializing ASIO driver"

This is VERY intermittent. I can get the ASIO driver working for a few minutes.
e.g. After i get past those 4 dialog boxes, I can switch to WDM mode, then
switch to ASIO mode and ASIO works. BUT if I do something like customize the
skin all of n-track locks up on me but when I relaunch ntrack I get the dreaded
diaglog "Error Initializing ASIO driver".

OS: Vista Ultimate
Sound Device: Line6 Toneport UX1 (LATEST drivers/firmware).

It's more stable using the Line6 WDM, but I want to run ASIO. Regardless of WDM
or ASIO, the Customize Skin window locks up the entire program 95% of the time.
Since I'm using Vista, I've tried running ntrack.exe "As Administrator", Ive
turned off UAC, I've uninstalled all my Line6 programs & drivers then
reinstalled. Uninstalled n-track... still no luck.

This is driving me nuts! Please email me if you require more info or
screenshots. Thanks.

Joe
------- Comment #1 From 2008-11-22 21:39:14 -------
Oops.. forgot to tell you version and build #.

V6.0.1 
Build: 2407
------- Comment #2 From 2008-11-22 23:55:57 -------
I upgraded to the latest beta version. Same issue. I changed my ASIO driver
from 24bit to 16bit and it has stabilized. No more ASIO initalization errors
and the Skin changing no longer locks up. I'm glad is has stabilized, however I
would like to run everything in 24 bit. Thanks
------- Comment #3 From 2008-11-23 19:48:28 -------
Okay. I GIVE UP. even after going back to 16 bit (which I shouldnt have to) it
stabilized for a couple of sessions. Now its locking up again when i simply try
to change the skin. I unhecked the two textured background checboxes... thats
all i want to do and it LOCKS UP ON ME. What is going on? yes I'm flustered,
yes I'm being unprofessional, YES IM PISSED.

I'm a devloper and I can write and debug programs, help me out here. If you
need more details let me get you on the phone because there are so many working
parts in n-track it's so hard to describe every action and every step i've
taken to reproduce my bugs. 

PLEASE HELP FAVIO.
------- Comment #4 From 2008-11-23 20:21:34 -------
I'm narrowing it down. I turned off Vista "User Account Control" and I'm not
getting the Error initializing ASIO. It it that my ASIO driver is not under UAC
control, aka, not being run as Administrator??

I apologize for my frustrations,but I have been frustrated big time. I hope my
comments do help figure out any bugs that may exist with ntrack and Vista UAC.
------- Comment #5 From 2008-11-23 20:33:16 -------
It no longer locks up on me with UAC turned off. I mean its not locking up for
me now, but after the 300 locks up's I have negative 200% confidence in n-track
v6. i.e I'm anticipating the next lock up.

So here's where I am in my bug woes.

1) It Locks up using ASIO 24bit mode (Line6 Toneport UX1)
2) ASIO Locks up when I have Windows Vista "User Account Control" turned on.

Now, I'm glad to have it working - though I had to pull my hair out trying to
figure out the issue(s). Now my two remianing problems are:

1) I WANT to run ASIO 24 bit (my card supports 24 bit)
2) I WANT to run UAC for my system security.

What do I do?
------- Comment #6 From 2008-11-24 04:11:15 -------
The problem with changing the skin sometimes causing the program to freeze has
been fixed in version in an early build of v6.0.2 Beta.

The UAC related problem is most likely a problem with the device's Asio
drivers, not with n-Track. n-Track is well behaved in respect to UAC issues and
all interactions with the file system and OS in general are with areas where
regular users (i.e. non-administrators) can read and write to.
You can however try with UAC on running n-Track as Administrator. To do that
you can browse to the n-Track installation folder (typically c:\Program
Files\FASoft\n-Track Studio 6, right click on ntrack.exe and select "Run as
Administrator" from the popup menu).

As for the lockup selecting 24 bit Asio drivers, it may be caused by an
incompatibility with the Toneport Asio drivers. Unfortunately we don't have a
Toneport to test with. I've sent you an email with instructions on how to set
up a remote assistance session so that we can try to find out what is causing
the freeze on your system.
------- Comment #7 From 2008-11-25 03:20:42 -------
Email from: hidden
Ok, the last thing I did after my last rant on bug 10 was to uninstall the
RTM version and install beta 6.0.2 (build 2145).

Skin lock ups: GONE
24bit ASIO: STABLE (with a few artifacts/hissing, but I'm messing with my
buffers to clear that up).
UAC turned on: STABLE

So essentially this build is not causing me any grief's.